Catastrophic FPS drop (60-70 to 5-10) on Valheim only

New Alienware R12(see below for details) with Nvidia 3070 was running everything fine (PUBG, Apex, and Valheim) then about two weeks ago my frame rate dropped from 60-70s to zilch (5-10). I have:
updated drivers
checked all graphics settings
lowered all graphic settings
moved around the world from densely populated area to isolated mountain top
reinstalled game

NOTHING HAS HELPED. !#$!#$!#$

I haven't yet rolled back the gpu software.

Again other games PUBG and Apex are running just fine.

Any help, suggestions, sympathetic curses appreciated,

TIA,
Jaya

System Profile Below:

OS Name Microsoft Windows 10 Home
Version 10.0.19043 Build 19043
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-IP7BHM1
System Manufacturer Alienware
System Model Alienware Aurora R12
System Type x64-based PC
System SKU 0A63
Processor 11th Gen Intel(R) Core(TM) i7-11700F @ 2.50GHz, 2496 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date Alienware 1.1.4, 7/8/2021
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Alienware
BaseBoard Product 0P0JWX
BaseBoard Version A00
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = "10.0.19041.1151"

Time Zone Pacific Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.7 GB
Available Physical Memory 19.2 GB
Total Virtual Memory 33.7 GB
Available Virtual Memory 17.2 GB
Page File Space 2.00 GB
Page File C:\pagefile.sys
Kernel DMA Protection On
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Is it near big buildings? I see that popping up continually related to Valheim.

Edit: have you tried these: https://steamcommunity.com/app/89297...

Location or density of builds does not impact FPS rate.
It was running great for weeks and then dropped to 5-10 fps.

My next move is to roll back my Nvidia drivers.

I think I've now diagnosed the problem: Steam is no longer working with my Nvidia GPU. Trying to set 3070 as preferred GPU but not having any luck. Chatting with Nvidia customer support right now. Really building up the cortisol now. 9 days off from work and can't play anything on Steam.

Jayavarman wrote:

I think I've now diagnosed the problem: Steam is no longer working with my Nvidia GPU. Trying to set 3070 as preferred GPU but not having any luck. Chatting with Nvidia customer support right now. Really building up the cortisol now. 9 days off from work and can't play anything on Steam.

That's insane

Time to jump on this free games on the Epic Store!

Jayavarman wrote:

I think I've now diagnosed the problem: Steam is no longer working with my Nvidia GPU. Trying to set 3070 as preferred GPU but not having any luck. Chatting with Nvidia customer support right now. Really building up the cortisol now. 9 days off from work and can't play anything on Steam.

you should be able to disable the integrated GPU in the bios.

Well, launching Valheim in Vulkan mode evidently forces Nvidia GPU but that hasn't solved the problem for the rest of Steam games, namely PUBG currently (yes, I'm still playing PUBG). And yes, all Epic and Origin games run fine. Got to get this fixed as I was hoping to get a lot of gaming in the next week.

Thinking back what I might have done to trigger this mishap. I initially thought it was a GPU driver update but I think I recall changing display settings but for the life of me I can't remember what.

Well back to Valheim until I get some help or insight.

Jaya

I'd reinstall Windows. You've got the time!