Tech help request: OLD HP Compaq 6200 PC (H2 socket) Motherboard

Hi folks,

this is way in the weeds over here. Appears I thought I was quite a bit smarter than I actually am. I bought a cheap motherboard on ebay, its a socket H2 from an HP Compaq 6200 Pro Desktop.

Silly me I thought I could plug in a standard power supply to it, but it doesn't look like I can.
Actually I have no idea what kind of power supply it is compatible with, or if there is a way to use a modern standard ATX power supply with it. It doesn't seem to have the common large power plug of a more modern system. Odd think is that I took apart an even older computer, I think an LGA 775 socket core duo or something like that, and this one did have the same common power plug I am used to.

So some questions:
Should most "regular" H2 socket motherboards be compatible with a modern power supply, or is this just asking too much? Is there a physical conversion of the power plugs that can make it compatible?

Any thoughts would be greatly appreciated!

manual for computer that the motherboard came from:

http://h10032.www1.hp.com/ctg/Manual...

I am starting to think maybe a board of this type just doesn't use the largest power connector and uses several smaller ones instead, still trying to figure it out.

To be clear you're talking about the cable from the power supply to the motherboard?

I believe you only need the 4 (2x2) or 6 prong (3x3) cable into the white receptacle.

Older power supplies will have a piece that splits off the larger 24 pin CPU power cable. Newer ones may not.

From another site, it looks like the PSU used in these HP machines is a custom job which does not conform to ATX standards.

https://superuser.com/questions/8696...

Thanks for the input folks.

Yup looks like i failed to account for the dell non standard issues.

Btw i went and bought another cheap old mb , actually another dell but one believed to be atx compatable e as well as compatable w my cpu. While i then needed another heat sink, as the mounting wasnt the same, despite it all being the same cpu socket type.

I did eventually get it working ! Yay!

Thanks again for the inputs !

If i get around to it i might start another thread noting what parts ended up working together in my cheap ass gaming upgrade build