Random Tech Questions you want answered.

They aren’t synced to iCloud?

If her contacts were synced to iCloud, you can (hopefully!) recover them easily: https://support.apple.com/guide/iclo...

Just did this the other day after using an app that was supposed to remove duplicate contacts and ended up deleting my own contact info. I'll just live with the dupes I guess!

Contacts on a SIM card is a blast from the past. I forgot that was even a thing.

Just got a new windows 10 laptop.

Downloaded a game from the epic store but it told me a .dll file was missing.

I replaced the file but then it told me that VCRUNTIME140.dll was missing.

Replacing the file doesn't work.

Ive also tried running the system file checker, and installing Visual C++ Redistributable for Visual Studio 2015.

Run it as Administrator?

Run windows update and make sure you have all of the latest stuff.

Robear wrote:

Run it as Administrator?

Doesn't work sadly.

LeapingGnome wrote:

Run windows update and make sure you have all of the latest stuff.

It says I can update to the new version of windows 10, version 21H1

By the way is this true?

On 64-bit Windows, you have c:\windows\system32 an c:\windows\sysWOW64, but the names are non-inuitive: system32 contains the 64-bit system files, and sysWOW64 contains files for 32-bit backward compatibility. Even c:\windows\system still exists, but it's empty as there's no 16-bit backward compatibility.

Because if it is I may just give up and never try trouble shooting again.

Ok so just for the hell of it I put a copy of the missing .dll into syswow64 which according to my last post shouldn't have made a difference?

I'm now getting The application was unable to start correctly (0xc000007b)

Ah fixed it!

Diwnloaded the 86x version of visual studio instead of the 64x version.

I hate these unhelpful labels but I'm happy it worked.

strangederby wrote:

By the way is this true?

On 64-bit Windows, you have c:\windows\system32 an c:\windows\sysWOW64, but the names are non-inuitive: system32 contains the 64-bit system files, and sysWOW64 contains files for 32-bit backward compatibility. Even c:\windows\system still exists, but it's empty as there's no 16-bit backward compatibility.

Because if it is I may just give up and never try trouble shooting again.

It is true. Windows is an incredibly shaky house of cards.

strangederby wrote:
LeapingGnome wrote:

Run windows update and make sure you have all of the latest stuff.

It says I can update to the new version of windows 10, version 21H1

There you go, first step is make sure you are up to date.

What software do you use/recommend for automatically backing up files on Windows to a USB drive? I'm already using OneDrive for backing up some data online but I'm paranoid so I also want an offline backup of some of my data like baby pictures and things.

I'm pretty tempted to just use rsync because at least I know it works.

Robocopy works just like rsync, but it's windows native. A simple robocopy script is my favorite for automated backups like that.

LouZiffer wrote:

Robocopy works just like rsync, but it's windows native. A simple robocopy script is my favorite for automated backups like that.

Sounds perfect. I’ll try that.

pandasuit wrote:
LouZiffer wrote:

Robocopy works just like rsync, but it's windows native. A simple robocopy script is my favorite for automated backups like that.

Sounds perfect. I’ll try that.

I also like SyncBack. Nice UI with tons of options

My phone screen wont turn on. I have a moto 5G ACE. I tried holding the power button down to force a reboot. I can hear the hello moto voice but the screen is still blank. Also tried to do a factory reset by holding down the volume button and power button but the screen still didn't come on.

Just got the phone in March.

Baron Of Hell wrote:

My phone screen wont turn on. I have a moto 5G ACE. I tried holding the power button down to force a reboot. I can hear the hello moto voice but the screen is still blank. Also tried to do a factory reset by holding down the volume button and power button but the screen still didn't come on.

Just got the phone in March.

Just jumped through all the hoops to have it repaired, Fun times asking me to do things that I can't do without a working display.

That is always special... I hate scripts!

Any possible water damage? My wife's iPhone had that same behavior after an accidental dunk, even though it was supposedly water resistant. Those fixit type places can usually repair it, but it might cost some $$.

None. It was working fine one minute went to sleep and never came back on.

Do you see any bulge in the body of the phone? It's possible the battery expanded and disrupted the screen's connector.

Baron Of Hell wrote:

None. It was working fine one minute went to sleep and never came back on.

I had that happen with my Nexus 5. 1 month past warranty and the best Google could do is offer to sell me a new phone at full price. Anyway, I let the battery die completely, used an old iPhone for a while, and came back to it a few months later and it came on fine after charging.

This is why I still do stuff like get paper boarding passes for flights.

NSMike wrote:

Do you see any bulge in the body of the phone? It's possible the battery expanded and disrupted the screen's connector.

Nope, even took off the case to check.