My Book 3TB Essential slow access

I have My Book Essential 3TB and I bought probably a year ago. At first it works as smooth as a baby panda's butt.
But a week ago, just as I transfer about 100Gb of my movies to "My Book", the access become very slow.
It would take around 15 minutes at My Computer untill the icons appear

IMAGE(http://sphotos-e.ak.fbcdn.net/hphotos-ak-ash3/q71/s720x720/563951_718319161518619_2062214093_n.jpg)

sometimes it takes an hour.

And after I get to access to the drive, it will take another 15 minutes untill all the folders is appear, sometimes it also takes an hour.

And when I play a song in "My Book" through Winamp, it takes around 30 seconds untill the music start.

Help, i'm so desperate. I might run into the wild naked and sing The Amazing Grace as slow as humanly possible if I can't access "My Book" like it used to be

What operating system are you running on your computer?

Have you tried accessing it from another machine?

B

BrandonCHFG wrote:

What operating system are you running on your computer?

Have you tried accessing it from another machine?

B

I use windows 7 Ultimate, i've tried using it in my old laptop and it's nothing different

Get the data off of there and start looking for another drive. After you gett the data off you could try a low level format (utilities are available from all the disk vendors for this type of stuff, I think seagate calls theirs the seatools) to see if that fixes it but drives fail and you'd rather be prepared than ignore warning signs.

The seatools should also have a diagnostic utility to tell you if the drive is failing as well to start the RMA process if it is still under warranty.

Just realized the MyDrive is most likely Western Digital, they have tools too that should diagnose and low level format too. The thing I would not do if it is still under warranty is take it out of the enclosure that most likely voids the warranty.

It's not USB3 and you accidentally moved it to a USB2 port or something right?

I had similar issues with MyBook and an approach similar to this worked for me. However, lie Eezy said, if it is still under warranty, RMA is a better option.

Thank you very much, i'm very grateful to u all