GWJ bugs, feature requests, and updates

I only use Firefox and I have not seen this either. Connecting using TLS 1.3 with no issues that I have noticed. Running Win 10.

So... I just went to confirm that I'm using TLS 1.3 as well, and this is what I saw:

Spoiler:

IMAGE(https://i.imgur.com/wMmjCO5.png)

Problem seems to be getting worse. It's happened twice today, and this second time took many retries before I was able to get through.

And my connection count is a mere 25,505.

edit: I think next time I'll go ahead and click the "restore default settings" button, and then go look to see what it blew up.

Malor, from what region of the world are you visiting the site?

The code that adds Amazon affiliate info to Amazon links has a tendency to break them. That code's gotta be at least 10 years old by now.

Definitely still seeing it. I adjusted my settings to default, and it instantly loaded. That could be coincidence, because it would always eventually do that anyway, but it worked twice, so I think that's probably it.

My only change to defaults has been to go into about:config and to set security.tls.version.min to be 3, which means TLS 1.2. If we're getting a NO_CYPHER_OVERLAP, that means Cloudflare must be advertising only TLS1.0 and 1.1 at me.

At this point, it's both safe and best practice to disable TLS1.0. I think even disabling 1.1 wouldn't matter very much.

TLS1.2 has been around a long while now, and probably anything that won't support it isn't safe to use anyway.

I'm pretty sure, at this point, that it's a Firefox bug. I've seen the NO_CYPHER_OVERLAP at least once on another site, and if I close and restart Firefox, that always fixes it.

I think there's something not getting cleared correctly as I move around, navigating between different sites.

We've had the option to specify our pronouns in our user profiles for a while now, and that's awesome. But I have to click through to profile pages to check someone's pronouns (or whether they've indicated them).

Could pronouns also appear as part of the avatar/tag/location block on each post?

As long as we have the option to turn the display off. I have no problem with preferred pronouns, I just don’t want them taking up space on every post.

doogiemac wrote:

Malor, from what region of the world are you visiting the site?

Like he'd ever post that publicly.

I think he's still in the US.

The obscenity filter converts the capital-f f-word to a censored lowercase f-word. It makes me look like a grammarless heathen. Intolerable!

Mixolyde wrote:

The obscenity filter converts the capital-f f-word to a censored lowercase f-word. It makes me look like a grammarless heathen. Intolerable!

That's why I always self-censor; that way I can write "WHATEVER THE F*CK I WANT" and ensure the preservation of grammar.

merphle wrote:
Mixolyde wrote:

The obscenity filter converts the capital-f f-word to a censored lowercase f-word. It makes me look like a grammarless heathen. Intolerable!

That's why I always self-censor; that way I can write "WHATEVER THE F*CK I WANT" and ensure the preservation of grammar.

This is what I do as well, because I feel the same exact way. Believe me, I've spent way too much time better spent elsewhere trying to rejigger it to allow me to swear in all-caps. I'm sorry.

You could probably just turn it off.

Quintin_Stone wrote:

The code that adds Amazon affiliate info to Amazon links has a tendency to break them. That code's gotta be at least 10 years old by now.

A fresh example of this, from the Deals thread: https://www.gamerswithjobs.com/node/...

Malor wrote:

You could probably just turn it off.

What? And lose the quaint charm that's been a staple since mumble-mumble?! f*ck that!

FÜCK!

Huh. I never really thought about it... what happens if I say f*ck?

f*ck?

Interesting.