GWJ bugs, feature requests, and updates

Nah, I get it, too. No AHK scripts. Tapping ctrl once clears it.

Hyetal wrote:

Nah, I get it, too. No AHK scripts. Tapping ctrl once clears it.

Same here. It just happens for me in Firefox, and hitting Ctrl resolves it.

It never happens in Safari though.

Chrome!

Scratched wrote:
muraii wrote:

I occasionally experience a feature whereby typing SHIFT + I generates the italics open tag, and doing so a second time generates the closing tag. Similarly, SHIFT + L launches the link dialog. I don't think this is my keyboard's sticky CTRL key, given that Google Chrome would launch the "inspect element" pane if so (I just tested it a few times). Is this a JQuery thingy feature? I'm using Chrome 19.0.1084.52 m on XP SP3.

I get that, but for me I suspect it's down to an AHK script I'm running to bind crtl+tab and ctrl+shift+tab (for effortless multi-tab browsing) to mouse buttons. Spamming ctrl when the unwanted opening tag shows up 'clears' it. No idea if it's something not quite right with the forum as it's quite rare to see it.

For reference, said AHK script:

#IfWinActive, ahk_class MozillaWindowClass
XButton1::Send ^{Tab}
XButton2::Send ^+{Tab}

I have some AHK stuff, too, and grab CTRL for some things. Without digging into it much further, I'll just try the CTRL-spamming.

Also, kudos on using the window classes. I'm grabbing window titles which is very inconsistent. I'll have to look into that more.

Yep. Longtime bug. Tap ctrl to fix. Happens in lots of browsers.

Site seemed brutally slow around lunch today. Noonish eastern and the hours before/ after. Thought things had been smoother since the issues a couple weeks back...

Any likelihood of ever getting an option to delete a post, at least within a given time window after a post?

We tend to get a lot of double (and triple in my case with my phone yesterday) posts when the site is running slow.

muraii wrote:

Also, kudos on using the window classes. I'm grabbing window titles which is very inconsistent. I'll have to look into that more.

It's pretty much a necessity on a browser.

Stele wrote:

Yep. Longtime bug. Tap ctrl to fix. Happens in lots of browsers.

Oh, it's CTRL? I've been doing CTRL+I. Happens all the time on Firefox when switching tabs for some reason.

Scratched wrote:
muraii wrote:

Also, kudos on using the window classes. I'm grabbing window titles which is very inconsistent. I'll have to look into that more.

It's pretty much a necessity on a browser.

Since AHK's WindowTitle attribute will match partials, and in my experience Firefox always includes "Firefox" in the window title, that matched well for me every time. I currently run Cygwin and use mintty as my terminal. I have a keymap that looks for "~" in the title of a window and hides/unhides. This matches mintty given I start it with the "-" switch. The only time it won't work is when I have an email with "~" in the window title. I haven't explored the conditions under which Outlook does this, and won't need to if I use a window class instead.

I'll put the "sticky-Ctrl" bug on my todo list. I've written the code for it before for a Firefox addon for another site, so hopefully I can just rip that out and reuse it as-is, with a few extra tags.

I always thought that was my ancient Model M not correctly sending release signals when it was supposed to. Glad it's not just me.

So, I've been noticing I have had titles such as and like Coffee Grinder and Intern. I have also noticed that other people's titles have been completly random and seem individually made. When can I have an awesome title like Super Spongebob Pedestrian Mocha Latte Dream Team?

EverythingsTentative wrote:

So, I've been noticing I have had titles such as and like Coffee Grinder and Intern. I have also noticed that other people's titles have been completly random and seem individually made. When can I have an awesome title like Super Spongebob Pedestrian Mocha Latte Dream Team?

Probably never. I'm fairly sure that's too many characters.

Titles are dependent on your post count. 1000 will net you a thread where people will suggest titles for you to choose from.

Example: http://www.gamerswithjobs.com/node/1...

This place is getting seriously frustrating during the day. I'm seeing repeated freezeups of extended duration, one to two minutes.

Malor wrote:

This place is getting seriously frustrating during the day. I'm seeing repeated freezeups of extended duration, one to two minutes.

Yeah why don't some of you jerks do some work while you're at work instead of slowing down the site?

LOL!

*slinks away, abashed*

Malor wrote:

This place is getting seriously frustrating during the day. I'm seeing repeated freezeups of extended duration, one to two minutes.

Tonight, I'm going to run the standard optimization routine I do every couple of weeks. Honestly, until we're migrated to Drupal 7 and on better hosting (trying to work that out with my employer), we'll see this happen. Our database is of a size that we can't efficiently optimize for the hardware we're on any more. I'm making good progress on the D7 migration from a data standpoint, but it'll be a little while still until that's done.

Does it ever make sense to make a 'cut' in a forum, to separate out legacy posts as a read-only archive and a new clean live forum? To a certain extent that seems like a workaround rather than a fix.

Anyone else unable to use the BB commands?

Check

See what I mean?

parallaxview wrote:

Anyone else unable to use the BB commands?

Check

See what I mean?

It's a function of your relatively short tenure on the board; with time, and more posts, you'll unlock the 'can use BB commands' cheevo

Tanglebones wrote:
parallaxview wrote:

Anyone else unable to use the BB commands?

Check

See what I mean?

It's a function of your relatively short tenure on the board; with time, and more posts, you'll unlock the 'can use BB commands' cheevo :)

There really does need to be some kind of indication of this down with the comment box. We have people asking about this way too often. Maybe you could replace the first two lines of the spiel below the text box with a boldface warning that BBCode and HTML have been disabled for their account at present?

Ahhh that makes sense-ish. Sorry to ask a repeated question!

I'm curious if there's any JSON or XML output of the forums. I asked about it here. If anyone knows, please feel free to answer in either thread. Thanks!!

Can we immediately ban anyone that makes a thread with the words 'official' and 'jersey' in the title? Or maybe just don't post the thread, your choice!

LeapingGnome wrote:

Can we immediately ban anyone that makes a thread with the words 'official' and 'jersey' in the title? Or maybe just don't post the thread, your choice!

Perhaps make it so that there's more restrictions on low rank members, or that if they make a thread it gets queued for a mod to approve it.

Scratched wrote:
LeapingGnome wrote:

Can we immediately ban anyone that makes a thread with the words 'official' and 'jersey' in the title? Or maybe just don't post the thread, your choice!

Perhaps make it so that there's more restrictions on low rank members, or that if they make a thread it gets queued for a mod to approve it.

It'd be more work for mods to approve posts than to delete the spam threads.

Has anybody ever looked into setting up an affiliate account for GWJ with Newegg? Lots of links here to newegg stuff that could be scripted to work with the affiliate program I'd think.

Not sure how lucrative those are vs Amazon affiliate deals.

FEATURE REQUEST
I think it'd be really useful and cool if the forums (Everything Else, P&C, Games, etc) had an icon indicating which threads where already in our favorites.

Have the forums been kind of slow for anyone else the last few days?

LeapingGnome wrote:

Have the forums been kind of slow for anyone else the last few days?

They were pretty awful all day Fri, and even quit responding totally for a few minutes around lunch.