WoW installation issues

Okay, so I've been having issues with my computer and I believe the external hard that I have WoW installed on is infected with a virus. I ended up having to do a complete destructive system restore on my laptop in order to even log in at all. No big deal, nothing really important lost, and I've already got it back up and running again with all the important programs and whatnot..... HOWEVER.....

I'm having problems installing WoW directly on my hard drive. At first it would get about 7% and would give me the following error:

An error was detected while verifying the contents of the file "C:\World of Warcraft\Data\common.MPQ". There may be a problem with your system, or with the drive at C:\. You can attempt to install again. If this problem persists, please contact Blizzard Technical Support.

I tried installing from my discs, using the online installer, copying the files from the disc to the computer and installing in safe mode, always the same error. I did have a little more success after doing a disc defrag, but I still got the error.... only at around 47-48% installed, rather than 7%. I've read about other people online having this issues, so I'm pretty sure it's not something wrong with my computer, unless it's a problem with the additional RAM I have installed. I'm going to try taking out the extra ram stick and installing, but if that doesn't work, what should I do?

make sure your anti virus is turned off when installing. it's been known to cause problems.