Automatic BBCode Insertion?

On my Mac Pro, Firefox will automatically insert BBCode tags whenever I type certain capital letters during composition. (I'm flustered, as it's not doing it for this post, but did it in the P&C one I wrote a few minutes back.) It does not do this on my XP PC. Any ideas what I can change to turn that off?

From what I've heard, it's an issue with the site Javascript code's ability to recognize when the control key has been pressed. Sometimes that flag gets stuck on. Whenever I encounter this issue on my XP machines, I tap both control buttons a couple of times and it goes away.

It does it for me too randomly ever since we switched to GWJ 3.0. I haven't found a way to fix it so I just roll with it.

Yeah, tapping CTRL will get rid of that problem. Unfortunately, only on a case-by-case basis, though. It's annoying as hell, especially when you get it with capital L's, when it brings up the Link dialog. I mentioned this in the "Lingering Bugs" thread, but there's validation on the cancel button for both the Link and Image dialogs when there shouldn't be. Cancel should just close the dialog, not check for proper input, so it takes 2 clicks to get rid of a dialog you didn't want.

Oh neat! Didn't realize ctrl+shift+(letter) would insert the bbc tags for me. Be prepared for more italics, bolding and strikethrus from me!

Edit: Strike the strikethrus, ctrl+shift+s does not insert them (Boo!) and ctrl+shift+b is bringing up my bookmarks.

Anyone have a rundown of the BBCode shortcuts? Like, maybe one for Youtube?

kaostheory wrote:

Oh neat! Didn't realize ctrl+shift+(letter) would insert the bbc tags for me. Be prepared for more italics, bolding and strikethrus from me!

Edit: Strike the strikethrus, ctrl+shift+s does not insert them (Boo!) and ctrl+shift+b is bringing up my bookmarks.

Yeah, it might conflict with your browser shortcuts.

ctrl+shift+j brings up an error console in Firefox. Never knew that was there.

Cool, thanks everyone.

This drives me nuts. In IE7 on my Vista desktop shift+I opens (or closes) an italic tag but does not do it in IE7 on my XP laptop.

Firefox in vista also ***sometimes*** inserts the italic tag with a shifted I. Annoying as hell.

Yeah, it's not consistent because sometimes the keyup event actually fires.